Avant-propos

Avant-propos Top Next
SITE CONSTRUCTION SET

Ces pages ont pour objectif d'aider le concepteur dans l'utilisation du SCS en donnant un maximum d'informations pour l'utilisation du logiciel d'intégration "SCS", non pour créer une application Scol fonctionnelle. Il est basé sur la version libre 2.x du SCS. Les informations présentent dans ce document peuvent ne pas être valables pour les versions commerciales antérieures (les versions commerciales sont obsolètes, Scol étant passé openSource).
Cette aide suit une utilisation linéaire (suivant les menus et les interfaces) plutôt que fonctionnelle car les approches peuvent être très différentes selon les créateurs.

Ce fichier d'aide est fourni tel quel sans aucune garantie. L'auteur ne peut être tenu responsable pour tout dommage résultant de son utilisation ou de son téléchargement.
Cette aide appartient au domaine public. Toute contribution est la bienvenue ! :-)

Les sources du présent fichier sont disponibles.

Cette aide a été intégrée avec le logiciel libre (licence Mozilla Public License) "HELPMAKER" : https://sourceforge.net/projects/helpmaker (en anglais)

aide SCS
version 1.0.1

Historique :
- Version 1.0.1 : Mise à jour du chapitre "Interface Modules". Traduction en anglais. Ecrite et compilée par : iri, octobre 2003
- Version 1.0 : Première version publique, intégrée au premier package officiel openSource du SCS. Ecrite et compilée par : iri, septembre 2003
- Versions antérieures : non publiques. Ecrites et compilées par : iri, juillet & août 2003


Qu'est-ce-que Scol ?

Qu'est-ce-que Scol ? Previous Top Next
La technologie Scol est un projet de r&d qui est né à l'issu du développement du "Deuxième Monde", l'un des tous premiers mondes virtuels sur internet, conçu et réalisé par Cryo pour le compte de Canal+ entre 1995 et 1997.

Les difficultés rencontrées lors du développement du "Deuxième Monde" ont poussé Cryo à développer une technologie dédiée aux applications multimédia et multi-utilisateurs.

Cette technologie, appelée initialement 'Magma' a finalement pris le nom de Scol (pour Standard Cryo On Line). Elle prend la forme d'une machine virtuelle comprenant un langage de programmation original, le langage Scol, et livrée sous deux formes : un logiciel serveur, et un plugin. La même machine virtuel, et donc le même langage Scol, fonctionnent donc côté client et côté serveur. La version cliente (ou "plugin") est dotée de nombreuses librairies multimédia, alors que la version serveur est conçue pour fonctionner sans interface graphique.

Les premières mentions publiques de la technologie Scol se trouvent dans un papier co-signé par Philippe Ulrich et Sylvain Huet pour Imagina 97 (Du numérique à la théorie des Mentas), ainsi que dans le livre de Daniel Ichbiah "Bâtisseurs de rêves".

On peut considérer la technologie Scol comme un outil commode dédié à la recherche suivante : "techniques et usages de la numérisation du synchrone."

Autrement dit : une fois que les interactions synchrones ont été numérisées, quel traitement informatique, quelle optimisation peut-on leur appliquer ? En quoi cette "prothèse" augmente-t-elle les capacités de l'Homme ?

La vision du projet est qu'en faisant interagir des individus à travers une machine (et pas uniquement à travers la voix et la vue comme dans la réalité), il sera possible de développer de nouvelles formes d'interactions, qui offriront de nouveaux modes de communication entre les individus.

Depuis la liquidation de groupe Cryo, intervenue à l'été 2002, le projet est poursuivi par ses passionnés et par ses fondateurs sous la forme d'un projet opensource (Manifeste pour le passage de Scol en Opensource)

SCOL est un langage aux finalités multiples. Ses applications ne se limitent pas uniquement à la construction de site web mais à toutes sortes de produits intégrant des technologies réseaux avec un fort potentiel intéractif.

Vous trouverez plus d'informations sur ces pages officielles :
  • Site de l'association pilotant désormais le projet Scol : http://www.scol-technologies.org
  • Site communautaire : http://www.scolring.fr.st/
  • Site de développements openSource : http://sourceforge.net/projects/scol

De nombreux sites sont référencés sur le Scolring ! N'hésitez pas à les visiter ! :-))

Mailing-listes :
  • scol-info@lists.sourceforge.net : informations générales (lecture seule)
  • scol-tech@lists.sourceforge.net : liste support technique et autres discussions (moins ou pas technique)
  • scol-devel@lists.sourceforge.net : liste développeurs (très technique)

Pour vous inscrire à une ou plusieurs de ces listes, allez à http://sourceforge.net/mail/?group_id=76682

< Scol Technologies License >

'Source code' license (BSD license) :
Copyright (c) 2003, organization : Scol Technologies Association, owner : Sylvain Huet
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
- Neither the name of the 'Scol Technologies Association' nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 'AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

'Scol Technologies' is a trademark. Therefore :
- The names 'Scol' and 'Scol Technologies' must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact Scol Technologies Association (www.scol-technologies.org).
- Products derived from this software may not be called 'Scol', nor may 'Scol' appear in their name, without prior written permission. For written permission, please contact Scol Technologies Association (www.scol-technologies.org).

'DMS' is a patented technology.
- The owner provides unlimited and free rights to implement this patent with the Scol programming language, and to use these implementations.
- Other kinds of implementation or use of the patent require prior written permission. For written permission, please contact Scol Technologies Association (www.scol-technologies.org).


Qu'est-ce-que le SCS ?

Qu'est-ce-que le SCS ? Previous Top Next
Le SCS est librement téléchargeable à l'adresse suivante :
http://scol-technologies.org

Le SCS est le logiciel le plus complet pour développer un site web 3d en Scol. Il existe aussi deux autres logiciels d'intégration Scol, moins complet : l'E_maginer et son ancêtre, le Cryonics.
Le SCS est disponible en installation standard sur les plateformes Microsoft Windows ® 9x, NT, 2000 et XP. Le SCS peut être installé manuellement sur un ordinateur équipé de GNU/Linux, sous réserves de modifications (pour utilisateurs experts uniquement) ; une version standard est en préparation.
Les plugins de lecture sont disponibles pour les plateformes Microsoft Windows ® 9x, NT, 2000 & XP, GNU/Linux, MacOS (*). (*) : MacOS X : version en cours de développement (09/2003), MacOS 9 : version 3.5 uniquement. Consultez le Scolring pour être informé des mises à jour.

Le developpement d'un tel site 3d ne nécessite nullement la connaissance du langage Scol. C'est l'un des intérêts majeurs ! Il s'agit en fait de reconstruire une sorte de puzzle. Votre site se découpe en pièces spécifiques : la 3d proprement dite, les avatars, le chat, la gestion des visiteurs, etc ... Chaque pièce peut éventuellement se composer de "sous-pièces". Dans le SCS, ces pièces sont représentées par des modules. Ils sont configurés simplement à la souris puis assemblés les uns par rapport aux autres suivant les résultats attendus.

Le SCS est fourni avec une cinquantaine de modules et presque autant de plugins pour la 3d. Vous pouvez ajouter sans difficultés vos propres modules ou ceux écrits par d'autres. Pour écrire vos modules, il vous sera cependant nécessaire de connaître le langage Scol.

Cette architecture DMS, pour Distributed Modules System, caractérise le SCS : vous pouvez ajouter, éditer ou supprimer des modules sans rien connaître au langage informatique qui les sous-tend. Vous n'avez qu'à établir des liens entre eux. Un peu comme une installation de plomberie, vous construisez le réseau de canalisations (les liens) en fonction des différents éléments de sanitaires évier, lavabo, douche... (les modules) dont vous avez besoin. Enfin, c'est une comparaison ! ;-))

Vous trouverez ici j'espère de quoi vous permettre de rejoindre la communauté active des Scolm@sters (créateurs de sites Scol) rapidement et facilement. N'oubliez pas de consultez également les sites de scol-technologies et du Scolring.


Installation & Désinstallation

Installation & Désinstallation Previous Top Next
  • Installation :

Le SCS est librement téléchargeable sous forme d'exécutable (une installation multi-fichiers existe pour les versions de développements). Une fois téléchargé, double-cliquez dessus et suivez les instructions qui s'afficheront. Deux cas de figure peuvent se présenter :
  1. Vous possédez déjà une version du Scol Voy@ger installée sur votre ordinateur :Le SCS doit être installé dans le répertoire du Scol Voy@ger (par défaut : C\:program files\scol)Si les librairies graphiques standard 2D et 3D ne sont pas incluses, vous pouvez les ajouter manuellement en créant un dossier "LIB" dans le répertoire ..scol\partition. Copiez-les dedans.Les autres librairies graphiques non standard et vos propres librairies peuvent être installées dans n'importe quel sous-dossier de ..scol\partition.Si la version de votre Scol Voy@ger est ancienne, celle-ci devrait être mise à jour. Cependant, je vous conseille de la désinstaller afin de n'avoir plus aucune référence et/ou conflit avec la version commerciale obsolète. La dernière version sera alors intégrée de façon totalement transparente.La première version libre (i.e. non commerciale) est la 4.0b
  2. Vous ne possédez pas de logiciels ou de plugin Scol déjà installés :Installez le SCS dans le dossier de votre choix. L'installation du Scol Voy@ger se fera automatiquement (obligatoire).Si les librairies graphiques standard 2D et 3D ne sont pas incluses, vous pouvez les ajouter manuellement en créant un dossier "LIB" dans le répertoire ..scol\partition. Puis copiez-les dedans.Les autres librairies graphiques non standard et vos propres librairies peuvent être installées dans n'importe quel sous-dossier de ..scol\partition.Support SQL :

Le support SQL n'est pas fourni d'office avec le SCS, car tous les systèmes ne l'intègrent pas.Pour l'installer, récupérer la version qui vous convient de scolSQL.dll sur http://sourceforge.net/projects/scol. Placez la dans le dossier ..scol/plugins. Editez les fichiers usm.ini et usmRess.ini :
  1. usm.ini :

ajoutez la ligne : Plugins\ScolSql.dll SCOLloadSQL
Enregistrez
2. usmRess.ini :
ajoutez les deux lignes suivantes : odbc.nom_odbc.login admin & odbc.nom_odbc.password admin
où nom_odbc est le nom de la base tel que déclaré dans le module ODBC et admin le login et mot de passe de l'administrateur de la base (admin par défaut).
Enregistrez.

Relancez le Scol Voy@ger pour que ces modifications soient prises en compte.
  • Désinstallation :

Si vous désirez supprimer le SCS de votre ordinateur, cliquez sur Démarrer puis Programme puis SCS puis Désinstaller ou sur Démarrer puis Panneau de Configuration puis sur Ajout/Suppression de programmes et sélectionnez SCS dans la liste. Suivez les indications portées à l'écran.

Si vous avez ajouté manuellement des fichiers et/ou des librairies personnelles, ceux-ci ne seront pas enlevés. Il vous faudra les supprimer manuellement.

Si vous avez conçu des sites Scol, ceux-ci ne pourront être ni édités ni lancés.

Si vous avez modifié des "*.pkg" du SCS ou des modules DMS, pensez à les sauvegarder.

Note aux développeurs :
Si vous désinstallez le SCS en vue d'une réinstallation du système d'exploitation, sauvegardez votre dossier Scol. Réinstallez votre OS, réinstallez basiquement le SCS et remplacez l'intégralité du dossier Scol par celui que vous avez précédemment sauvegardé. Attention : cette astuce n'est valable que si vous réinstallez la même version du SCS et est fournie sans aucune garantie.


Généralités

Généralités Previous Top Next
La technologie Scol peut servir à de nombreux projets. Elle n'est pas limitée à la création de sites web 3d.
Le SCS est l'outil le plus performant pour créer ce type d'application, même si la 3d n'est pas obligatoire.
Le principe général est de concevoir une application réseau (internet ou local) et de faire transiter des informations entre les utilisateurs (les clients) directement ou via le serveur. Plus rarement, transmettre des données uniquement d'un client vers le serveur.

Pour cela il est nécessaire de construire une partie cliente et une partie serveur.
Pour ne pas compliquer inutilement la chose, l'architecture DMS (Distribued Modules System) donne l'opportunité de passer outre ces questions clientes/serveur souvent obscures. Le créateur se concentre uniquement sur les fonctionnalités propres à son site, le tout se faisant à la souris ! :-)

Dans le SCS, seules les interfaces graphiques des clients (visiteurs/utilisateurs) et du serveur sont à faire (Partie Cliente et Partie Serveur). Les fonctionnalités se résument au choix des modules nécessaires et aux liens entre eux (Partie Modules).

Un conseil : pensez à enregistrer régulièrement votre travail et à sauvegarder l'ensemble de vos fichiers sources ! Des plantages de Microsoft Windows ® ou des disques durs peuvent survenir ! ;-)

Vous trouverez, outre un forum actif, de nombreux tutoriaux et exemples sur le site communautaire http://scolring.fr.st.


Liens officiels

Liens officiels Previous Top Next
Vous trouverez plus d'informations sur ces pages officielles :
  • Site de l'association pilotant désormais le projet Scol : http://www.scol-technologies.org
  • Site communautaire (Scolring) : http://scolring.fr.st/
  • Site de développements openSource : http://sourceforge.net/projects/scol

De nombreux sites sont référencés sur le Scolring ! N'hésitez pas à les visiter ! :-))

Mailing-listes :
  • scol-info@lists.sourceforge.net : informations générales (lecture seule)
  • scol-tech@lists.sourceforge.net : liste support technique et autres discussions (moins ou pas technique)
  • scol-devel@lists.sourceforge.net : liste développeurs (très technique)

Pour vous inscrire à une ou plusieurs de ces listes, allez à http://sourceforge.net/mail/?group_id=76682


Généralités

Généralités Previous Top Next
A l'ouverture, le SCS affiche une interface composée de deux parties :
  1. En haut, les menus, sous forme d'icônes cliquables;
  2. En dessous, une large zone grise sur laquelle seront placés les modules à intégrer (dans ce cas, cette zone grise sera le SHELL) et les interfaces pour la partie cliente et la partie serveur.


Menu Fichier

Menu Fichier Previous Top Next
  • Nouveau (CTRL + N) :

Lance un nouveau projet avec les paramètres par défaut.
  • Ouvrir (CTRL + O) :

Ouvre un projet déjà existant. Seuls les projets présents dans le dossier Partition (ou un de ses sous-dossiers) seront valides.
Par défaut, la boite de dialogue suppose des fichiers à l'extension ".dms" (format du SCS 2.x). Pour ouvrir un projet réalisé avec une version 1.x du SCS, sélectionnez dans le menu déroulant du bas le format "scs1 *.scs".
  • Fichiers récents :

Affiche la liste des derniers projets ouverts.
  • Fermer (CTRL + A) :

Ferme le projet courant. (Attention au raccourci !)
  • Enregistrer (CTRL + S) & Enregistrer sous (CTRL + MAJ + S) :

Enregistre le projet courant au format scs 2 (*.dms). L'enregistrement se fait dans le dossier Partition (ou un de ses sous-dossier).
  • Quitter (CTRL + Q) :

Ferme le(s) projet(s) en cours et ferme le SCS.
Si vos projets n'ont pas été enregistrés, une boite de dialogue vous demandera ce que vous désirez faire.


Menu Edition

Menu Edition Previous Top Next
  • Supprimer (Suppr) :

Supprime l'élément sélectionné (module, lien, zones, ...)
  • Annuler (CTRL + Z) :

Supprime la dernière action effectuée (revient à l'état juste avant).
  • Rétablir (CTRL + Y) :

Supprime l'annulation précédente. Il y a plusieurs niveaux d'annulation (voir Historique (F11))
  • Couper (CTRL + X) Copier (CTRL + C) & Coller (CTRL + V) :

Coupe, copie et colle un module d'un projet sur autre projet par exemple en gardant les liens internes (mais les liens vers les autres modules ne seront pas gardés)
  • Importer :

Permet d'importer un fichier "*.dme" ou "*.dmi". Le premùier format est spécifique au SCS 2.x. Au préalble, il aura fallu exporter un module sous ce même format ! Il gardera ainsi toutes ces caractéristiques et pourra être directement utilisé.
Le second format est spécifique des versions antérieures (SCS 1.x).
  • Exporter :

Exporte un module avec sa configuration (format "*.dme"


Menu Affichage

Menu Affichage Previous Top Next
  • Arbre du site (F5) :

La popup liste les éléments du site selon que ce soit les Modules, la partie Cliente ou la partie Serveur qui est active. Un élément sélectionné dans cette liste sera également mis en valeur dans la fenêtre mère (la fenêtre principale avec un fond gris !). Un double-clique l'éditera.
Dans le 1er cas (partie Modules active), l'arbre du site comportera la liste des modules déjà intégrée au projet (généralement dans l'ordre de création).
Dans les autres cas (partie Cliente ou Serveur active), la liste affichera les documents et, en retrait, les zones qui y sont associées.
  • Arbre de création / association (F6) :
  1. Dans la partie Module, ce sera l'arbre de création. Tous les modules disponibles y sont classés par type. Double-cliquez sur l'un d'entre eux pour l'éditer puis l'intégrer à votre projet. Plusieurs instances d'un même module peuvent être intégrées au sein d'un même projet.
  2. Dans les parties Clientes ou Serveur, il s'agira de l'arbre d'association. Il permet d'associer les modules intégrés aux différents éléments de votre interface.

  • Propriétés (F7) :

Affiche la liste des modules (ou des zones) avec les liens associés. Double-cliquer dessus permet de les éditer.
  • Options du site (F8) :

Comme son nom l'indique, cette popup permet de paramétrer globlament le site. Basiquement :
- le nom du site,- le numéro de port server (une seule application doit utilisée un port précis à un moment donné). Par défaut c'est le 3000.
- le nom de l'auteur du site et son adresse email,
- la langue du site et une brève description.
Un mot de passe peut être demandé pour filtrer l'accès au site (mot de passe unique).
Une image représentant votre site pour le futur annuaire des sites Scol (en jpeg ou png serait bien).
Le temps d'inactivité client indique au bout de combien de ms de connexion nulle, un visiteur est réputé déconnecté du serveur.
Le contenu du fichier scol du site n'a normalement pas à être changé. Cependant, si un script particulier doit être exécuté au lancement du serveur, insérer sa ligne de commande ici.
  • Hébergement :

Hébergement de site proposé, autre que l'hebergement personnel.
  • Erreur (F10) :

Affiche les erreurs (tous types ou par types selon la sélection du menu déroulant en haut de la popup). Cliquez sur une erreur et un message spécifique sera disponible dans le champ inférieur.
  • Historique (F11) :

Permet de gérer le niveau d'annulation et de rétablir des versions précédentes.
  • Préférences (F12) :

Sélectionnez chaque item et cochez la case pour valider.
  1. Configuration générale :

Aide utilisateur : affiche les info-bulles,
Apparition automatique fenêtre d'erreurs : la fenêtre d'erreur (ci-dessus) s'ouvre dès qu'une erreur survient.
Fonte par défaut : police de caractères utilisée pour l'interface du SCS,
Taille de la liste des fichiers récents : nombre maximum de projets dans Fichiers récents du menu Fichier.

2.Options du Projet :
Montrer seulement les liens sur les modules : permet d'afficher (case cochée) les liens uniquement du module sélectionné. Cette option est recommendée pour éviter d'avoir l'interface noyée sous les liens. Cependant, au début, il peut être utile de tous les voir pour comprendre le fonctionnement.
Aide détailée : avoir des infos bulles plus détailées,
Sauver le site avant upload : enregistrement automatique lors de l'upload du site chez l'hebergeur.


Menu Projet

Menu Projet Previous Top Next

Ce menu est différent selon la partie (Modules, Clientes ou Serveur) active.
  • Créer une blacbox :

Disponible pour la partie Modules.
Shématiquement, une blackbox est un module dans lequel est placé d'autres modules ayant des entrées/sorties communes afin de créer des liens uniques vers les modules externes à celle-ci.
  • Entrer dans une blackbox (Entrée) :

Disponible pour la partie Modules.
Permet d'ouvrir une black box et d'éditer les modules contenus.
  • Créer un documents fils (Entrée) :

Disponible dans les parties Client ou Serveur.
Crée un document popup sur l'interface principale.
  • Créer une zone fille (Espace) :

Disponible pour les parties Client et Serveur.
Dans un document (père ou fils) préalablement sélectionné, crée un élément de l'interface graphique en relation avec un ou plusieurs modules déjà intégrés.
  • Sélectionner l'élément père (Retour arrière) :

Disponible dans les 3 parties.
Sélectionne l'élément supérieur hiérarchiquement.
Dans une blackbox, cette action réouvrira le shell primaire ; une zone sélectionnée permettra de remonter au document la contenant.


Actions, Evénements & Liens

Actions, Evénements & Liens Previous Top Next
Une action se fait en amont d'un module : elle indique à celui-ci d'exécuter quelque chose de précis à un moment déterminé.
Par exemple jouer la musique "sonnerie.wav" ajouté au module SoundEnvironment.

Un événement se fait en aval d'un module : quelque chose se produit dans le module qui génère un message.
Par exemple, le visiteur clique sur la porte d'entrée d'une maison.

Un lien est un couple (Evénement / Action) : le message généré suite à l'événement provoque l'action sur le module considéré.
Par exemple, le visiteur clique sur la porte d'entrée (événement clic dans le module C3D3) provoque la lecture du la musique "sonnerie" du module SoundEnvironment.
La musique ne se déclenchera que lors du clic sur la porte et à aucun n'autre moment.


Shell

Shell Previous Top Next
Le Shell est un module atypique. Il est la couche primaire de tout serveur DMS. C'est pour cette raison qu'il est présent par défaut dans tout site dès la création d'un projet.
Ses rôles principaux est de lancer d'autres modules et de définir les points d'entrées des avatars dans les cellules 3d.

Il n'y a aucune action. Les événements disponibles sont au nombre de six :
enter | Chargement des modules ...
full |
in | Le site est chargé ...
log | Informations loguées (généralement relié à l'action du même nom du module Log)
out | Le site va être fermé ...
start | Le site est lancé ...

Le shell est matérialisé par le fond uniforme qui tapisse le SCS. Cliquez droit n'importe où hors de l'icone d'un module pour afficher le menu contextuel des événements.


Modules

Modules Previous Top Next
Les modules DMS sont des éléments non autonomes effectuant des tâches prédéfinies au niveau serveur et/ou au niveau client. Ce sont leurs relations entre eux et avec le Shell qui forment un ensemble cohérent et utilisable.

Généralement, les modules ont un domaine d'activité précis : 3d, son, multimedia, base de données, interface, etc ... C'est pourquoi ils sont classés par type dans l'Arbre de création (touche F6 du clavier).

Pour ajouter un module à votre site, double cliquer sur son icône dans l'Arbre. Sa fenêtre d'édition s'ouvrira. Une instance est créée Cette popup permet de personnaliser sa configuration :
  • un nom pour l'instance,
  • eventuellement des paramètres spécifiques au module.

Une aide spécifique à chaque module est accessible en cliquant sur le bouton "?" en haut à droite de toute fenêtre d'édition. Celle-ci se décompose ainsi :
  • Nom, version, catégorie et date de mise à jour
  • Ces fonctions (= son utilisation)
  • Sa configuration
  • Sa mise en oeuvre (= son intégration dans le SCS).

Le bouton "OK" valide et ferme l'éditeur du module.
Le bouton "Appliquer" se contente de valider les paramètres saisis.
Le bouton "Annuler" ferme l'éditeur et détruit l'instance si celle-ci venait juste d'être créée, si celle-ci existait déjà, les éventuelles modifications ne seront pas validées.

Les actions et événement attachés sont expliqués dans l'aide propre au module. Il en est de même pour les zones associées.

Il existe plusieurs catégories de modules qui regroupent ceux ayant des utilisations connexes. Dans l'arbre de création, ils sont classés dans des "dossiers" ("3d", "admin", "avatar", ...)
Les catégories satandards sont :
  • 3d
  • Admin
  • Avatar
  • Bots
  • DB (= DataBase)
  • Games
  • Interf (=Interface 2d)
  • Media
  • Sound
  • Tools

Pour le module C3D3, il existe des plugins qui lui apportent des fonctionnalités supplémentaires. Celles-ci sont généralement implémentées dans l'onglet Instances de ce module. Shématiquement, une instance est une copie spécifique du plugin pour obtenir tel ou tel effet. Un même plugin peut être utilisé plusieurs au sein d'un même module, grâce à ce principe de copie (instances).


Liens

Liens Previous Top Next
  • La création d'un lien (cf Actions, Evénements & Liens) requiert une petite gymnastique qui se révèle vite machinale à l'usage ! :-)

Un lien est constitué d'un événement (le "déclencheur"), un message qu'il ne sera généralement pas nécessaire de paramétrer ni de conditionné, et une action.

En premier, il faut déterminer quel est le module "déclencheur". Une fois fait, cliquez droit sur son icône et sélectionnez l'événement correspondant.
Un lien part du module vers le curseur de la souris. Cliquez droit sur le module récepteur et choisissez l'action désirée.
Le lien est établi.
  • L'édition d'un lien s'effectue en double cliquant sur le "rond" coloré situé au milieu du lien (entre les deux modules concernés).

Une pop up s'ouvre permettant de supprimer un lien ou de le configurer :

Pour enlever un lien, cliquez dessus pour le sélectionner et appuyez sur la touche SUPPR du clavier.
Pour le configurer, renseignez les champs"Paramètres du lien" et/ou "Conditions du lien". Dans la plupart des cas, il n'est pas nécessaire de les remplir. Voyez l'aide des modules concernés pour plus d'informations. Des tutoriaux expliquent comment personnaliser ces liens. Vous les trouverez référencés pour la plupart sur le Scolring (http://scolring.fr.st)


Liste standard

Liste standard Previous Top Next

Le SCS est fourni avec des modules standard. C'est eux qui permettent l'élaboration du contenu du site. Le seul module intrinsèquement lié au SCS est le Shell.
Ils sont accessibles par l'Arbre de création du SCS dans le menu Affichage ou touche F6 du clavier. Seuls les modules utiles à votre projet sont à intégrer !
CATEGORIES | NOMS | UTILISATIONS
3D | C3D3 | Le module C3D3 est le module central de tout site SCOL en 3D. Il gère les objets3d, les textures, les effets associés (par le biais des instances ci-dessous).Si l'on désire plusieurs scènes 3d différentes, il est possible d'intégrer plusieurs C3D3 sur le Shell Dans ce cas, chacun doit porter un nom différent.C'est ce module qu'il faut utiliser pour intégrer de la 3d à votre site.
 | PLUGINS 3D | Il en existe plus d'une quarantaine. Ils permettent d'appliquer des effets de toutes sortes sur les objets 3d ou leurs textures ou d'ajouter des fonctionnalités précises au C3D3, de la modification de textures à la création d'environnement sonore 3d.Vous les trouverez dans l'éditeur du C3D3 sous les onglets Instances et Plugins.
ADMIN |  | Permet la gestion globale du site :
 | ALERT | Permet de créer des alertes visuelles sur l'interface serveur.
 | BAN | Permet de bannir un utilisateur d'un site
 | CONNECTIONS | Permet d'afficher le nombre de visiteurs d'un site à chaque instant
 | CONTACT | Permet de lancer l'interface cliente en local (sur la machine serveur)
 | CONTROL | Permet de réaliser une interface d'administration du site sur l'interface cliente.
 | COUNT | Permet de réaliser des statistiques sur différentes périodes sur divers évènements
 | DAILYDIFF | Permet de créer un filtre au niveau serveur
 | DYNPASS | Permet la gestion de mot de passe de façon dynamique
 | GREP | Permet de créer des filtres au niveau client
 | LOG | Permet d'enregistrer sur le serveur diverses informations en provennce des modules
 | LOGIN | Permet de gérer les pseudonymes des visiteurs
 | LOGINP4 | Permet de gérer, d'enregistrer, d'administrer les pseudonymes des visiteurs dans une base de données
 | SOUNDALERT | Permet de créer des alertes sonores
 | STARTSCOL | Permet de déconnecter un visiteur, de fermer ou de démarrer un serveur à distance
 | STATS | Permet de créer des statistiques de visites
 | TRAFFIC | Permet de visualiser la fréquentation d'un site
AVATAR |  | Permet la gestion des avatars (= représentation visuelle) des visiteurs
 | AV3D | Permet à un utilisateur de prendre un avatar en trois dimensions
 | CHGAV | Permet à un utilisateur de changer de type d'avatar (2d, 3d, webcam, ...)
 | CHGPHOTO | Permet de modifier l'image affichée sur l'avatar
 | PHOTO3 | Permet la gestion des images des avatars
BOTS |  | Permet d'intégrer des automates dans le site pour simuler des visiteurs ou des modérateurs.
 | BOTS0 | Permet d'intégrer un robot personnalisé
COMMTOOLS |  | Permet la création et la gestion des moyens de communications entre les utilisateurs.
 | CHATROOM | Permet d'intégrer un espace privé de communication écrite entre certains visiteurs
 | DIRREG | Permet l'enregistrement et la mise à jour des informations d'un site Scol sur un annuaire.
 | FTP | Permet de gérer un espace FTP sur la machine serveur
 | HTTPSERVER | Permet de créer un serveur HTTP pour page HTML lié au serveur Scol
 | INTERACTIVITY | Permet de créer un système de visio-conférence
 | INOUT | Permet de gérer les relations avec l'"extérieur" (= hors site Scol)
 | IRC | Permet d'intégrer un channel irc comme chat.
 | MAIL | Permet d'envoyer des mails à partir d'un site Scol.
 | MAILINGLIST | Permet de gérer une mailing list sur un site Scol.
 | PAGER | Permet une communication écrite privée entre deux utilisateurs.
 | TOCOMMUTRON | Permet de gérer le commutron dans un site Scol
 | VOTE | Permet d'intégrer une interface de vote et des résultats induits
 | WHITEBOARD | Permet d'intégrer un tableau blanc (dessin)
DB |  | Permet l'interfaçage entre un site Scol et des bases de données.
 | ITEMS | Permet la gestion des données
 | LOADINFOS | Permet la mise à disposition des données aux aute modules
GAMES |  | Permet d'intégrer des jeux Scol
 | CHESS | Permet d'intégrer un jeu d'échec
 | GOBAN | Permet d'intégrer un jeu de Go
 | LOTO | Permet d'intégrer un jeu de Loto
 | SCORE | Permet de gérer les scores obtenus aux jeux
INTERF |  | Permet la création et la gestion des éléments d'interface 2D.
 | BANNER | Permet l'affichage de bannières défilantes dans un site Scol.
 | BUTTON | Permet l'affichage et la gestion d'un bouton standard
 | COLORTERM | Permet la gestion d'un chat public.
 | GRAPHICBUTTON | Permet la gestion d'un bouton personnalisé graphiquement
 | GRAPHICCHECKBOX | Permet la gestion d'un bouton personnalisé à plusieurs états
 | INPUT | Permet la saisie de chaines de caractères et leurs récupérations pour d'autres modules.
 | LISTBOX | Permet d'intégrer une liste d'éléments cliquables
 | MEETINGPOINT | Permet de créer et gérer un annuaire des utilisateurs connectés
 | NAVIGATION | Permet d'afficher des sphères de déplacements 3D.
 | SITE MAP | Permet d'afficher une carte du site
 | TEXT | Permet d'afficher des fichiers texte
MEDIA |  | Permet d'intégrer des fichiers audio et images
 | MEDISEQUENCE | Permet la gestion de fichiers multimedia
 | QUICKTIME | Permet de difuser du contenu au format QuickTime
 | REALPLAYER | Permet de diffuser du contenu dans un format lisible par les players de Real.com
SOUND |  | Permet d'intégrer des envirronements sonores
 | SOUNDENVIRONMENT | Permet d'intégrer des environnements sonores en fonction d'évènements
 | SPEAKER | Permet de créer et de gérer un chat vocal
TOOLS |  |
 | BITMAP | Permet d'afficher des images BMP ou JPEG.
 | CONTX | Permet d'intégrer des ActiveX
 | EXCLUSION | Permet de gérer les entrées/sorties des visiteurs d'un monde 3D
 | HTTPsrvRess | Permet de générer et de partager certaines ressources entre utilisateurs.
 | ICONIFY | Permet de réduire l'interface serveur à une icône ou de la restaurer.
 | IGNORE | Permet la gestion de visiteurs mis en ignore par un ou plusieurs autres utilisateurs.
 | PASSWORD | Permet l'affichage et la gestion de mots de passe.
 | POINTS | Permet de simuler un aiguillage pour l'établissement de liens
 | QUIZZ | Permet de poser des questions par popoup
 | RANDOM | Permet la génération d'un nombre aléatoire
 | SEQUENCE | Permet de lancer des actions en fonction d'une série précise d'évènements
 | SYNCHRO | Permet de lancer une action en fonction d'éveneements réalisés
 | TELEPORTMANAGER | Permet la gestion d'un téléport
 | TIMER | Permet de créer un chrono pour déclencher des actions à des intervalles réguliers.

Cette liste n'est pas exhaustive.Il existe aussi des modules et des plugins spécifiques ou développés par des tiers qui peuvent être intégrés sans difficulté au SCS.


Documents et zones

Documents et zones Previous Top Next
Les documents sont les fenêtres de l'interface dans lesquelles des zones seront placées correspondant aux éléments visibles des modules.

L'interface cliente se compose toujours du document dit père : ce sera la fenêtre primaire du site. A partir de lui, il est possible de définir autant de documents dit fils, correspondant à des fenêtres popups.
Pour les créer, sélectionnez le document père et appuyez sur la touche Entrée du clavier (ou allez sur le menu "Projet | Créer un document fils".

Les éléments graphiques des modules intégrés (par exemple, le chat, les boutons, la vue 3d, etc ...) doivent être associés à des zones. Il est impossible de les associer à un document. Consultez l'aide du module pour connaître la ou les zone(s) nécessaire(s) à son bon fonctionnement.

Pour associer une fonction d'un module à une zone, appuyez sur F6 (ou allez au menu "Affichage | Arbre de la création / association"). Sélectionnez une zone. Repérez le module dans la liste et cliquez la croix le précédent pour déroulant ces fonctions. Sélectionnez celle qui vous intéresse puis cliquez sur le bouton "Associer à la zone courante" (en haut).

Une même zone cliente peut contenir plusieurs fonctions. Veillez à ce qu'aucune ne puisse être affichée simultanément !


Edition des documents et des zones

Edition des documents et des zones Previous Top Next
L'édition d'une zone permet de :
  • donner un nom à la zone,
  • modifier la couleur de fond (sous le SCS),
  • afficher une bitmap comme fond (uniquement si aucun module n'est associé à cette zone),
  • modifier sa position et sa taille,
  • configurer son comportement en cas de redimensionnement par l'utilisateur,
  • voir et/ou supprimer les modules associés.

Pour enlever une association, sélectionnez-la et appuyez sur la touche SUPPR de votre clavier.

W1, W2, W3 = distance entre le bord gauche du document et le bord gauche de la zone, entre le bord gauche et le bord droit de la zone (la largeur de la zone), entre le bord droit de la zone et le bord droit du document la contenant.
H1, H2, H3 = distance entre le bord haut du document et le bord haut de la zone, entre le bord haut et le bord bas de la zone (la hauteur de la zone), entre le bord bas de la zone et le bord bas du document la contenant.
Pensez à cliquer dans un autre champ pour valider la modification de ces valeurs !

Une double-flèche indique que la distance concernée (sur l'illustration ci-dessus il s'agit de W3 ou de H3) pourra être modifié si l'utilisateur redimensionne le document. L'absence de double-flèche indique que cette distance demeurera fixe. Il doit toujours y avoir au moins une distance variable en largeur et en hauteur.


Documents et Zones

Documents et Zones Previous Top Next
Les documents sont les fenêtres de l'interface dans lesquelles des zones seront placées correspondant aux éléments visibles des modules.

L'interface serveur se compose toujours du document dit père : ce sera la fenêtre primaire du site. A partir de lui, il est possible de définir autant de documents dit fils, correspondant à des fenêtres popups (généralement il n'y a pas de popup pour l'interface serveur car celle-ci est le plus souvent rudimentaire).
Pour les créer, sélectionnez le document père et appuyez sur la touche Entrée du clavier (ou allez sur le menu "Projet | Créer un document fils".

Les éléments graphiques des modules intégrés (par exemple, le log, le bouton contact , des alertes visuelles, etc ...) doivent être associés à des zones. Il est impossible de les associer à un document. Consultez l'aide du module pour connaître la ou les zone(s) nécessaire(s) à son bon fonctionnement.

Pour associer une fonction d'un module à une zone, appuyez sur F6 (ou allez au menu "Affichage | Arbre de la création / association"). Sélectionnez une zone. Repérez le module dans la liste et cliquez la croix le précédent pour déroulant ces fonctions. Sélectionnez celle qui vous intéresse puis cliquez sur le bouton "Associer à la zone courante" (en haut).

Une zone (serveur) n'est normalement associée qu'à un seul module.


Edition des documents et zones

Edition des documents et zones Previous Top Next
L'édition d'une zone permet de :
  • donner un nom à la zone,
  • modifier la couleur de fond (sous le SCS),
  • afficher une bitmap comme fond (uniquement si aucun module n'est associé à cette zone),
  • modifier sa position et sa taille,
  • configurer son comportement en cas de redimensionnement par l'utilisateur,
  • voir et/ou supprimer les modules associés.

Pour enlever une association, sélectionnez-la et appuyez sur la touche SUPPR de votre clavier.

W1, W2, W3 = distance entre le bord gauche du document et le bord gauche de la zone, entre le bord gauche et le bord droit de la zone (la largeur de la zone), entre le bord droit de la zone et le bord droit du document la contenant.
H1, H2, H3 = distance entre le bord haut du document et le bord haut de la zone, entre le bord haut et le bord bas de la zone (la hauteur de la zone), entre le bord bas de la zone et le bord bas du document la contenant.
Pensez à cliquer dans un autre champ pour valider la modification de ces valeurs !

Une double-flèche indique que la distance concernée (sur l'illustration ci-dessus il s'agit de W3 ou de H3) pourra être modifié si l'utilisateur redimensionne le document. L'absence de double-flèche indique que cette distance demeurera fixe. Il doit toujours y avoir au moins une distance variable en largeur et en hauteur.


Exécuter

Exécuter Previous Top Next
L'icone Exécuter (F9) lance le site sur le PC sur lequel tourne le SCS.
Si nécessaire, un enregistrement du projet est automatique.
L'interface serveur s'affichera. Si un module "contact" a été correctement intégré, il sera possible de lancer l'interface cliente en local = sur la machine serveur).

Dans le dossier où le projet a été enregistré, un fichier "nom_du_projet.scol" a été automatiquement généré. Il contient le script de lancement du site. C'est sur lui qu'il faut double-cliquer pour lancer manuellement le site.

Si une erreur apparaît lors de la compilation du site, une fenêtre d'erreur s'affiche. Le site ne pourra pas être lancé tant que l'erreur ne sera pas résolue. Si l'erreur vous semble obscure, éditez les fichiers de log générés (..\scol\partition\log). Pour les utilisez pleinement, pensez à configurer le Scol Voy@ger de façon adéquate (cf documentation du Scol Voy@ger).
Si des ressources manquent (typiquement des objets 3d ou des textures), celles-ci seront listées, avec leurs chemins relatifs.


Hébergement personnel

Hébergement personnel Previous Top Next
Avec le SCS, vos sites peuvent être hébergés directement sur votre ordinateur. Il vous faut pour cela une connexion Internet. Vous devrez communiquer l'adresse IP de votre serveur à vos visiteurs.
Si votre connexion n'est pas permanente ou si votre IP est dynamique (ce qui est le cas en RTC ou en ADSL par exemple), il sera nécessaire d'utiliser les services de sociétés proposant la redirection d'IP. Certains sont gratuits comme chez "DynDns" (http://www.dyndns.org) ou "XDir" (http://www.xdir.org) par exemple (liste non exhaustive).

Lancez votre site avec la commande Exécuter du SCS ou double-cliquez sur le fichier "nom_du_site.scol" du répertoire d'enregistrement du site.
L'interface serveur se chargera et votre site sera accessible depuis le réseau (local ou internet).

L'adresse de votre site sera alors :

- scol://adresse_IP:nom_du_site
ex : scol://212.123.456.789:monSite

- scol://adresse_redirigée:nom_du_site
ex : scol://user.dyndns.org:monSite

- scol://nom_de_domaine:nom_du_site
ex : scol://www.mon_domaine.com:monSite

"nom_du_site" peut être remplacé par le numéro de port défini dans les propriétés du site :
ex : scol://adresse_IP:numero_de_port
scol://212.123.456.789:3000

Une de ces adresses devra être saisie pour accéder à votre site.
Le nombre de visiteurs simultanés n'est limité que par la bande passante de votre connexion et par les ressources disponibles de votre serveur.

Ce thème est traité par des tutoriaux. Visitez le Scolring.

Note : il est possible d'héberger plusieurs sites sur un même ordinateur. La seule contrainte est d'avoir un numéro de port différent pour chacun.


Hébergement professionnel

Hébergement professionnel Previous Top Next
Votre site peut être hébergé par un professionnel à condition qu'il dispose :
  1. du serveur Scol
  2. des librairies standard

Si le site a été conçu avec les librairies standard, vous uploaderez directement le fichier "nom_du_site.dms" selon les indications fournies par votre hébergeur.
Si vous avez utilisez des librairies personnelles, contactez-le avant toute procédure de transfert.

L'adresse et les éventuelles limitations d'accès vous seront communiquées par celui-ci.


Référencement

Référencement Previous Top Next
Le référencement d'un site est primordial pour assurer sa popularité et son existence sur le réseau. Outre les outils classiques, le Site Directory recence spécifiquement les créations SCS :
  • nom du site
  • adresse du site
  • nom de l'auteur
  • accessible ou non accessible (typiquement ouvert ou fermé)
  • nombre de visiteurs connectés
  • description du site (image & texte)

Pour vous référencer, vous devez intégrer le module "DirReg" (fourni par défaut avec le SCS). Complétez les champs de l'éditeur (voyez l'aide associée) puis créez les deux liens suivants :
  1. shell.in -> dirReg.update
  2. shell.out -> dirReg.update

Le Site Directory est directement accessible par le Scol Voy@ger ou sur le Scolring.

Il vous est également conseillé de référencer vos conceptions Scol sur le Scolring (notamment dans la galerie). Voyez ce site pour plus d'informations.


Serveur dédié

Serveur dédié Previous Top Next
Si vous possédez un serveur dédié ou si vous hébergez de nombreux sites, il est vivement recommandé d'installer le Serveur Scol (versions Microsoft Windows ® ou GNU/Linux).
Son principal intérêt réside dans l'administration simple et centralisée des sites hébergés et de leurs besoins.

Vous pouvez le télécharger sur SourceForge : http://sourceforge.net/projects/scol
Voyez la documentation officielle pour l'installation et la gestion du serveur.


Ajout/Suppression de modules

Ajout/Suppression de modules Previous Top Next
Vous pouvez enlever ou ajouter des modules à la liste.
Pour en enlever, supprimer simplement le dossier dans l'arborescence Scol : chaque module se trouve exclusivement dans un dossier précis. Typiquement, les dossiers des modules se trouvent dans le dossier "..scol\partition\dms\"
Ouvrez le SCS, appuyez sur F6 (ou allez au menu "Affichage | Arbre de création") et cliquez sur le bouton "Reconstruire".

Pour en ajouter, placez le dossier suivant les indications du concepteur du site. Ouvrez le SCS, appuyez sur F6 (ou allez au menu "Affichage | Arbre de création") et cliquez sur le bouton "Reconstruire". Le nouveau module sera opérationnel.


Formats de fichier

Formats de fichier Previous Top Next

Fichiers SCS :
  • Fichier exécutable :

*.scol : contient les scripts de lancement du site (plus généralement de toutes les applications écrites en Scol).
  • Fichier de description Projet :

*.dms : version SCS 2.x
*.scs : version SCS 1.x
  • Fichier module :

*.dme : version SCS 2.x, exportation d'un module
*.dmi : version SCS 1.x
  • Fichier de description d'interface :

*.dms : version SCS 2.x
*.scc : version SCS 1.x

Fichiers ressources :
  • Graphiques : JPEG, BMP, PNG, TIF (en export)

  • 3d : m3d

  • Audio : WAV, MIDI

  • Multimedia : WAV, MIDI, MP3, RM & associés, MOV, WMP & associés

  • Internet : HTML et tout langage supporté (js, jar, .activeX, ...)


How To

How To Previous Top
  • Comment installer ou désinstaller le SCS ? Réponse

  • Comment ajouter un module à mon site ? Réponse ...

  • Comment ouvrir un site réalisé avec une version antérieure du SCS ? Réponse ...

  • Comment importer ou exporter des modules déjà configurés ? Réponse ...

  • Qu'est-ce qu'un événement, une action ? Réponse ...

  • Comment modifier le nom de mon site ? Réponse ...

  • Comment éditer un lien ? Réponse ...

  • Comment changer le port d'écoute de mon serveur ? Réponse ...

  • Comment spécifier mon nom comme créateur du site ? Réponse ...

  • Comment configurer le SCS ? Menu Affichage

  • Comment créer une zone dans mon interface cliente ? Réponse ...

  • Qu'est-ce-que le shell ? Réponse ...
  • Est-il envisageable d'héberger soi-même son site Scol ? Réponse
  • Comment référencer mon site ? Réponse

  • Comment puis-je trouver des informations complémentaires ?

Vous trouverez plus d'informations sur ces pages officielles :
  1. Site de l'association pilotant désormais le projet Scol : http://www.scol-technologies.org
  2. Site communautaire : http://scolring.fr.st/
  3. Site de développements openSource : http://sourceforge.net/projects/scol

De nombreux sites sont référencés sur le Scolring ! N'hésitez pas à les visiter ! :-))

Mailing-listes :
  1. scol-info@lists.sourceforge.net : informations générales (lecture seule)
  2. scol-tech@lists.sourceforge.net : liste support technique et autres discussions (moins ou pas technique)
  3. scol-devel@lists.sourceforge.net : liste développeurs (très technique)

Pour vous inscrire à une ou plusieurs de ces listes, allez à http://sourceforge.net/mail/?group_id=76682